2024-06-24 16:55 (월)
HPE 아루바 네트워킹 제품에서 중대한 취약점 발견...긴급 업데이트
상태바
HPE 아루바 네트워킹 제품에서 중대한 취약점 발견...긴급 업데이트
  • 길민권 기자
  • 승인 2024.05.03 16:56
이 기사를 공유합니다

HPE 아루바 네트워킹에서 최근 네트워킹 인프라의 중대한 보안 취약점이 발견되어 광범위한 시스템이 원격 코드 실행(RCE) 공격에 노출될 가능성이 있는 것으로 밝혀졌다.

이러한 취약점이 악용될 경우 위협 행위자가 영향을 받는 시스템을 손상시키고 상승된 권한으로 임의의 코드를 실행할 수 있어 조직의 네트워크 보안에 심각한 위험을 초래할 수 있다.

총 10개에 달하는 이 취약점은 주로 인증되지 않은 버퍼 오버플로 취약점을 특징으로 하며, 특히 악용될 수 있는 강력한 수단이다. 이 취약점 중 4가지 취약점은 공통 취약점 점수가 9.8점으로 심각도가 심각한 것으로 평가되어 해결하지 않을 경우 심각한 영향을 미칠 가능성이 있는 것으로 나타났다.

확인된 중대한 취약점은 다음과 같다.

1. CVE-2024-26304: PAPI 프로토콜을 통해 액세스하는 L2/L3 관리 서비스의 인증되지 않은 버퍼 오버플로 취약점
2. CVE-2024-26305: PAPI 프로토콜을 통해 액세스하는 유틸리티 데몬의 인증되지 않은 버퍼 오버플로 취약점
3. CVE-2024-33511: PAPI 프로토콜을 통해 액세스되는 자동 보고 서비스의 인증되지 않은 버퍼 오버플로 취약점
4. CVE-2024-33512: PAPI 프로토콜을 통해 액세스하는 로컬 사용자 인증 데이터베이스의 인증되지 않은 버퍼 오버플로 취약점

이러한 취약점은 L2/L3 관리 서비스, 유틸리티 데몬, 자동 보고 서비스, 로컬 사용자 인증 데이터베이스 등 아루바OS의 다양한 구성 요소의 결함에서 비롯된다. 이 취약점을 악용하면 프로세스 응용 프로그래밍 인터페이스(PAPI) UDP 포트(8211)로 향하는 특수하게 조작된 패킷을 사용하여 공격자가 기본 운영 체제에서 임의의 코드를 실행할 수 있다.

영향을 받는 시스템에는 아루바 센트럴에서 관리하는 모빌리티 컨덕터(이전의 모빌리티 마스터), 모빌리티 컨트롤러, WLAN 게이트웨이 및 SD-WAN 게이트웨이가 포함된다. 이 취약점은 10.5.1.0 이하, 10.4.1.0 이하, 8.11.2.1 이하, 8.10.0.10 이하를 비롯한 여러 버전의 ArubaOS에 영향을 미친다. 또한 아루바OS 10.3.x.x 및 아루바OS 8.9.x.x와 같이 유지보수 종료 상태에 도달한 버전도 여전히 익스플로잇에 취약한 상태다.

이러한 취약성으로 인한 위험을 완화하기 위해 사용자는 HPE 아루바 네트워킹에서 제공하는 최신 보안 패치를 적용할 것을 권장한다. 또한 아루바OS 8.x의 임시 해결 방법으로 사용자는 기본값이 아닌 키를 사용하여 향상된 PAPI 보안 기능을 활성화하여 잠재적 악용에 대한 추가적인 보호 계층을 제공할 수 있다.

이러한 보안 업데이트를 즉시 적용하지 않으면 조직이 악의적인 공격에 취약해져 민감한 데이터에 대한 무단 액세스, 네트워크 중단, 재정적 손실이 발생할 수 있다.

■ 보안 사건사고 제보 하기

▷ 이메일 : mkgil@dailysecu.com

▷ 제보 내용 : 보안 관련 어떤 내용이든 제보를 기다립니다!

▷ 광고문의 : jywoo@dailysecu.com

★정보보안 대표 미디어 데일리시큐 / Dailysecu, Korea's leading security media!★