2024-06-24 20:00 (월)
익스프레스 엔진, XSS 취약점 발견…업데이트!
상태바
익스프레스 엔진, XSS 취약점 발견…업데이트!
  • 길민권
  • 승인 2012.02.09 19:25
이 기사를 공유합니다

보안패치 적용된 최신버전 1.5.1.6 이상으로 업데이트해야!
국내 PHP기반의 공개 웹 게시판인 익스프레스 엔진에서 크로스 사이트 스크립팅(Cross Site Scripting) 취약점이 발견됐다.
 
취약한 버전을 사용하고 있을 경우, 홈페이지 해킹에 의한 관리자 계정 탈취 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치가 필요하다.
 
영향받는 소프트웨어는 익스프레스 엔진 1.5.1.5 및 이전 버전이다.
 
기존 익스프레스 엔진 사용자는 업데이트가 적용된 상위 버전으로 업그레이드해야 한다. 패치 작업 이전에 원본 파일은 백업해야 하고 익스프레스 엔진을 새로 설치하는 이용자는 반드시 보안패치가 적용된 최신버전(1.5.1.6 이상)을 설치해야 한다.
 
◇용어 정리
-PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어
-XSS (Cross Site Scripting) : 웹사이트 관리자가 아닌 이가 웹페이지에 클라이언트 사이드 스크립트를 삽입하여 다른 사용자가 이를 실행하게끔 허용하는 취약점
-익스프레스엔진 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크
 
<참고사이트>
-www.xpressengine.com/index.php?mid
[데일리시큐=길민권 기자]
■ 보안 사건사고 제보 하기

▷ 이메일 : mkgil@dailysecu.com

▷ 제보 내용 : 보안 관련 어떤 내용이든 제보를 기다립니다!

▷ 광고문의 : jywoo@dailysecu.com

★정보보안 대표 미디어 데일리시큐 / Dailysecu, Korea's leading security media!★